Problem on Windows 7 64 bit machines

Questions, comments and suggestions concerning VintaSoft Twain .NET SDK.

Moderator: Alex

Post Reply
Abacus
Posts: 2
Joined: Mon Mar 15, 2010 12:07 am

Problem on Windows 7 64 bit machines

Post by Abacus » Mon Mar 15, 2010 12:23 am

Win 7 64 bit machines return "Library not initialized" error on start.
TwainAdvanced.exe in "C:\Program Files (x86)\VintaSoft\VSTwain.NET.6_0\Bin\v2.0\64-bit" folder works properly but when I try TwainAdvanced sample in Visual Studio i get the error.

Did I have to do anything else for 64 bit machine?

Thanks,
D.

Abacus
Posts: 2
Joined: Mon Mar 15, 2010 12:07 am

Re: Problem on Windows 7 64 bit machines

Post by Abacus » Mon Mar 15, 2010 4:54 am

Update:
This error is gone if compiled as x86. Now works but I do not see the WIA option that I see on a 32 bit machine.
Also only works if scanner UI is suppressed.

Thanks,
D.

Alex
Site Admin
Posts: 1444
Joined: Thu Jul 10, 2008 2:21 pm

Re: Problem on Windows 7 64 bit machines

Post by Alex » Sat Mar 20, 2010 10:41 am

Hello,
This error is gone if compiled as x86.
Yes, you should compile your project in x86 mode on 64 bit systems.
Now works but I do not see the WIA option that I see on a 32 bit machine.
I think your device does not have WIA driver for 64 bit systems.
Also only works if scanner UI is suppressed.
Please send information about your device, snippet of your code and log-file to support@vintasoft.com and we will try to fix the problem.

Best regards, Alexander

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest