Bad protocol error on device.open

Questions, comments and suggestions concerning VintaSoft Twain .NET SDK.

Moderator: Alex

Post Reply
ricrempel
Posts: 1
Joined: Thu May 02, 2013 9:22 pm

Bad protocol error on device.open

Post by ricrempel » Thu May 02, 2013 9:40 pm

When I call Device.open, I get a Twain Error: "General failure in response to DAT_CAPS. Bad protocol error."

This happens in my own code, but also in the demos provided by VintaSoft. The error is shown in a message box, displayed by the scanner software.

My scanner is a VistaScan, used to scan dental radiographies, so not a very common equipment.

After I close the message, scanning proceeds and I can acquire the images.

My setup: Windows 8 64bits, VintaSoftTwain.NET SDK 8.3 (x86), scanner uses Twain 1.9. Same problem happens on a Windows 7 machine. I have tried changing various parameters, to no avail.

I'm about to purchase Vintasoft's solution, but cannot until this problem is solved. Please, can someone help me?

Thanks!

Alex
Site Admin
Posts: 1464
Joined: Thu Jul 10, 2008 2:21 pm

Re: Bad protocol error on device.open

Post by Alex » Fri May 03, 2013 9:16 am

Hello,

Please generate log-file and send it to our support team at support@vintasoft.com for analyze.

Here are steps which you should do if you want to generate an extended log-file of scanner's work:
1. Enable logging (add the lines below to code of your application):
TwainEnvironment.EnableDebugging("d:\vstwain.log")
TwainEnvironment.DebugLevel = DebugLevel.Debug
2. Run your application.
3. Send us a log-file and detailed description of the problem.

Best regards, Alexander

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests