Scanners not detected in the hosted Citrix environment

Questions, comments and suggestions concerning VintaSoft Twain .NET SDK.

Moderator: Alex

Post Reply
manik@smartvault.com
Posts: 2
Joined: Mon Jun 27, 2011 8:39 pm

Scanners not detected in the hosted Citrix environment

Post by manik@smartvault.com » Mon Jun 27, 2011 8:43 pm

Our software uses VintaSoft.Twain version 4.2.0.1 and recently we deployed our software in a hosted "Citrix" environment. The software has been working great on a standalone desktop but when it comes to hosted Citrix environment, seems like it's failing to detect scanners and our drop down list comes back empty.

Is there anything different we are supposed to do in the hosted environment (using Citrix)?
Are we suppose to apply any patch/hot-fix for VintaSoft.Twain which has a fix for this issue?

note: We have followed the steps for troubleshooting the TWAIN redirection under
http://support.citrix.com/article/CTX107411 but no luck.

Thanks in advance

Alex
Site Admin
Posts: 1474
Joined: Thu Jul 10, 2008 2:21 pm

Re: Scanners not detected in the hosted Citrix environment

Post by Alex » Tue Jun 28, 2011 8:22 am

Hello Manik,

Are you able to load and open TWAIN device manager? (DeviceManager.Open method)

Best regards, Alexander

manik@smartvault.com
Posts: 2
Joined: Mon Jun 27, 2011 8:39 pm

Re: Scanners not detected in the hosted Citrix environment

Post by manik@smartvault.com » Tue Jun 28, 2011 9:19 am

Hi Alex,

Thanks for looking into this issue.

Since the issue is with customer side production environment I cannot debug it but there is no exception during the execution and nothing in the log file as well so I am assuming all the calls succeeded, I am not so sure about DeviceManager.Open method , seemingly we are not using it.

Following is what the snippet looks like, seems like Twain.SourcesCount returned 0.

Note1: This code works without any issue on a standalone desktop.
Note2: We are using VintaSoft.Twain version 4.2.0.1.

internal static Vintasoft.Twain.VSTwain OpenTwain()
{
Vintasoft.Twain.VSTwain twain = new Vintasoft.Twain.VSTwain();
twain.StartDevice();
return twain;
}

public IEnumerable<IScanSource> Devices
{
get
{
List<IScanSource> sources = new List<IScanSource>();
try
{
using (Vintasoft.Twain.VSTwain Twain = OpenTwain())
{
for (int i = 0; i < Twain.SourcesCount; i++)
sources.Add(new TwainScanner(i, Twain.GetSourceProductName(i)));
}
}
catch (Exception e)
{
Logger.Error(e);
throw new ScanConnectFailureException("Vintasoft.Twain", e);
}
return sources;
}
}

Thanks in advance,
--Manik

Alex
Site Admin
Posts: 1474
Joined: Thu Jul 10, 2008 2:21 pm

Re: Scanners not detected in the hosted Citrix environment

Post by Alex » Tue Jun 28, 2011 3:13 pm

Hello Manik,

Why don't you use the latest (8.0) version of VintaSoftTwain.NET SDK?

The last version is more better and fast than version 4.2.

DeviceManager.Open method is equivalent of twain.StartDevice() method.

Best regards, Alexander

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests