JavaScript Warning on Fillable Form

Questions, comments and suggestions concerning VintaSoft PDF .NET Plug-in.

Moderator: Alex

Post Reply
tplambeck
Posts: 15
Joined: Wed May 08, 2019 7:09 pm

JavaScript Warning on Fillable Form

Post by tplambeck »

I recently implemented logic to use interactive forms in one of my applications. It works great but on some forms I open I get a pop up message entitled JavaScript Warning and this message: "The PDF file requires a newer version of Adobe Reader. Press OK to download the latest version or see your system administrator."

Running the most current version of Acrobat so not sure why this happens. Anyway to suppress the pop up? Using version 9.0.0.21 of Imaging and 6.0.0.21 of PDF libraries.

Thanks!
Alex
Site Admin
Posts: 1975
Joined: Thu Jul 10, 2008 2:21 pm

Re: JavaScript Warning on Fillable Form

Post by Alex »

Hello,

In most cases this message means that you have PDF XFA document. XFA was deprecated in PDF 2.0 and VintaSoft Imaging .NET SDK does not support PDF XFA documents.

Here is code that allows to determine whether PDF document has XFA form:

Code: Select all

public static bool IsPdfDocumentWithXfaForm(Vintasoft.Imaging.Pdf.PdfDocument pdfDocument)
{
    if (pdfDocument.InteractiveForm != null)
    {
        if (pdfDocument.InteractiveForm.XFAResource != null || pdfDocument.InteractiveForm.XFAResources != null)
            return true;
    }
    return false;
}
Best regards, Alexander
Post Reply